IT技術にまつわる実験ノート

「長編を書くより、短編を数多く完成させてください。それが上達への近道です」 by 手塚治虫

自作Webアプリ「IT勉強会用 名刺ジェネレーター」を公開しました!ぜひご活用ください😀

https://it-benkyoukai-meishi.herokuapp.com/

can't find gem bundler (>= 0.a) with executable bundle に対応する

エラー発生

f:id:matt-note:20190129215619p:plain

 

うーん、gem install bundler でインストールしたのだが…。

f:id:matt-note:20190129215720p:plain

 

どうやら、原因は bundler のバージョンが異なるためとのこと。

f:id:matt-note:20190129215834p:plain

 

Gemfile.lock ファイルを確認してみる。

f:id:matt-note:20190129220828p:plain

そういえば、この前に bundler が 2.0 にバージョンアップしてたっけなぁ…。

 

というわけで、以下のコマンドを実行する。

  • gem uninstall bundler -v 2.0.1
  • gem install bundler -v 1.17.0
  • rbenv rehash