IT技術にまつわる実験ノート

「長編を書くより、短編を数多く完成させてください。それが上達への近道です」 by 手塚治虫

自作Webアプリ「IT勉強会用 名刺ジェネレーター」を公開しました!ぜひご活用ください😀

https://it-benkyoukai-meishi.herokuapp.com/

rbenv で Ruby 2.6.2 にアップデートして Rails を動かしてみる【Ubuntu】

rbenv でインストールできる Ruby のバージョンを出力してみると、2.6.2 が見当たらない。

  • rbenv install -l | grep 2.6

f:id:matt-note:20190410164251p:plain

 

rbenv をアップデートする。【参考:https://github.com/rbenv/rbenv-installer

 

これで Ruby 2.6.2 をインストールできるようになった。

f:id:matt-note:20190410164520p:plain

 

Ruby 2.6.2 をインストールする。

  • rbenv install 2.6.2

 

特定のディレクトリで Ruby 2.6.2 を使う場合は、以下のコマンドを実行して、.ruby-version ファイルを作成する。.ruby-versionファイルがあって、バージョンが設定されている場合は、この設定はしない。

  • rbenv local 2.6.2

 

これで Rails を動かそうとすると、以下のようなエラーになった。
f:id:matt-note:20190410164241p:plain

 

Ruby 2.6.2 で Rails をインストールする。

  • gem install rails --no-document

 

gem をインストールする。

  • bundle

 

これで Rails が動くようになった。

f:id:matt-note:20190410202550p:plain